These pages are maintained as a historical record of the former GINX.

     
 

BGP Samples

This shows a minimal Cisco router configuration to connect to GINX. The config should also work with Zebra. You should note that this config is provided for reference only, and is not a complete, working version. In particular, ingress and egress filtering has largely been left out of this configuration.


hostname example
!
service password-encryption
enable password 8 4DLfgySD4gCEE
!
ip subnet-zero
!
interface FastEthernet0/0
 description MY UPLINK (USE YOUR OWN NETWORK INFO!)
 ip address 10.0.0.2 255.0.0.0
 no shutdown
! 
interface FastEthernet0/1
 description GINX LINK
 ip address 192.42.99.254 255.255.255.128
 ip access-group 100 out
 speed 10
 duplex full
 no cdp enable
 no shutdown
!
router bgp 65050
 bgp router-id 192.42.99.254
 network 10.0.0.0/8
 neighbor 192.42.99.200 remote-as 65000
 neighbor 192.42.99.200 next-hop-self
 neighbor 192.42.99.200 route-map set-metric out
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
no ip http server
!
access-list 100 deny ip host 0.0.0.0 any
access-list 100 deny ip 127.0.0.0 0.255.255.255 255.0.0.0 0.255.255.255
access-list 100 deny ip 10.0.0.0 0.255.255.255 255.0.0.0 0.255.255.255
access-list 100 deny ip 172.16.0.0 0.15.255.255 255.240.0.0 0.15.255.255
access-list 100 deny ip 192.168.0.0 0.0.255.255 255.255.0.0 0.0.255.255
access-list 100 deny ip 192.0.2.0 0.0.0.255 255.255.255.0 0.0.0.255
access-list 100 deny ip 169.254.0.0 0.0.255.255 255.255.0.0 0.0.255.255
access-list 100 deny ip 240.0.0.0 15.255.255.255 any
access-list 100 permit ip any any
no cdp advertise-v2
no cdp run
!
route-map set-metric permit 10
 match ip address all
 set metric 1000
!
end
 
 
Valid XHTML 1.0! Valid CSS! Creative Commons License